From: "Haase, Konstantin" Date: 2011-01-11T18:22:16+09:00 Subject: [ruby-core:34341] Re: ext/bigdecimal/lib/bigdecimal/util.rb On Jan 11, 2011, at 10:12 , Charles Oliver Nutter wrote: > On Mon, Jan 10, 2011 at 8:35 PM, Yukihiro Matsumoto wrote: >> I agree with this patch, only when bigdecimal/util is explicitly >> loaded. In fact, I don't want to see no more to_x (x is any single >> character) conversion methods in the core libraries. > > It may or may not be germaine to this discussion, but because JRuby > users often want to show their intent to coerce Ruby objects to many > different Java types, we add a "to_java" method on all objects when > Java support is enabled. It accepts one parameter: the type of object > to which the object should be coerced (usually a Java class). A > similar "generic" to_* protocol for Ruby would be nice to have. > Something like #to_any? > > - Charlie I find #to_any a bit confusing as in "12".to_any(Integer). Why not just call it #to? Also, I like the idea. Konstantin