From: Zeno Davatz Date: 2011-01-11T16:59:42+09:00 Subject: [ruby-core:34336] [Ruby 1.8-Feature#4239] Let's begin a talk for "1.8.8" -- How's needed for surviving 1.8? Issue #4239 has been updated by Zeno Davatz. Hi I believe that we do need a 1.8.8 Release. The simple reason for that is: Otherwise the Road to 1.9.2 will be to bumpy for many who want to do the switch from Ruby 1.8.6 to Ruby 1.9.2. We want to do that switch. But we do not want to break our Neck doing so. A good example is the Oniguruma Patch. We need it in all our legacy applications. As Michael Fellinger points out here: http://url.ba/00z0 the Oniguruma Functions where not copied 100% into Ruby 1.9.2. Anybody who used the Oniguruma-Patch will expect the same functions in Ruby 1.9.2 - well and then they get burned as Michael Fellinger did. Implicitly this tells the user to jump over a huge crevasse. Releasing Ruby 1.8.8 will smoothen the jump to Ruby 1.9.2 for many loyal Ruby Users. We are doing Ruby since over 10 years. Yui Naruse pointed out that Ruby 1.8.6 has become to stable. If that is so you could also say that the transition to Ruby 1.9.2 is still to impractical for many people. People are actually afraid to switch. The goal for Ruby should be to make it more practical for users to switch to Ruby 1.9.2. At the moment it seems like you are pushing people into to the Crevasse, watching as they drop. I think that is a reason why Lucas Nussbaum quit http://url.ba/vets It is simply not possible for us to just "jump" to Ruby 1.9.2. Our codebase is to large. We have to switch slowly. By releasing 1.8.8 everybody will have an easier transition period and users will feel more compelled to switch to Ruby 1.9.2. At the same time Ruby 1.9.2 can catch up with 1.8.8 in the sense that it will at least support the same feature _and_ more, not less. Take Oniguruma as an example. I strongly believe that the Oniguruma Patch should be applied to Ruby 1.8.8 because of the above reasons. I do not understand why that patch was never applied to Ruby 1.8.6 in the first place. Oniguruma still provides many more functions then Ruby 1.9.2 does. Ruby 1.9.2 should build on the functions Oniguruma achieved because many people are already using Oniguruma in the very stable 1.8.6. Why breaks stuff that is working great? Enterprises and normal users care about one thing: Consistency. For further understanding I also wrote a blog post about this: http://just.do/2011/01/10/a-vote-for-ruby-1-8-8/ Matz says that consistency is not necessarily his goal. I think the clear decision should be when to be inconsistent. I believe the inconsistency should happen between Ruby 1.9 and 2.0. Not between Ruby 1.8.x and 1.9. The reason: Because being inconsistency should be communicated in advance. If you look at the kernel release cycle then I think that is a good example. Linus releases a new Kernel version every few weeks. I boot into every new rc-release (that I pull from git) and in 98% of the cases my machine comes up. Linus explicitly says that he only accepts big changes and new features in rc1 releases and then distills those down up to rc8 and then he pushes out the new stable release. So people know: Be adventurous in rc1 but work towards being stable with rc8 because a stable release should be a stable release. Think about the normal user. The average joe-normal-user. Do not make his life miserable. Help him upgrade to the great 1.9.2! Slowly. Best Zeno PS: We do not use Rails. ---------------------------------------- http://redmine.ruby-lang.org/issues/show/4239 ---------------------------------------- http://redmine.ruby-lang.org