From: Roger Pack Date: 2010-04-16T05:38:15+09:00 Subject: [ruby-core:29541] Re: [Feature #2152] Split functionality of Float#inspect and Float#to_s >> The option previously proposed is >> >> Float#to_s : human >> Float#inspect : verbose >> >> Another option: >> >> Float#to_s : verbose >> Float#inspect : verbose >> Float#to_hs : human (or to_ps or what not, for pretty string--not sure > Why to have two methods (to_s and inspect) doing the same thing? > They are not supposed to be aliased, > this is the case in many objects (except the ones having a unique perfect > representation). Good point. Because of this +1 for first option mentioned, from me. It would seem in this instance that we do actually prefer two methods, and two already exist for us to use. Thanks! -rp