From: Benoit Daloze Date: 2010-04-15T04:10:35+09:00 Subject: [ruby-core:29520] Re: [Feature #2152] Split functionality of Float#inspect and Float#to_s --001636417499996b4a0484371f11 Content-Type: text/plain; charset=ISO-8859-1 > > The option previously proposed is > > Float#to_s : human > Float#inspect : verbose > > Another option: > > Float#to_s : verbose > Float#inspect : verbose > Float#to_hs : human (or to_ps or what not, for pretty string--not sure > if there is a convention for that name or not) > > Any feedbacks or preferences there? I'd probably be ok either way. > -rp > > I think a new name would not be so welcomed (and confusing). Why to have two methods (to_s and inspect) doing the same thing? They are not supposed to be aliased, this is the case in many objects (except the ones having a unique perfect representation). So let's change one ! I think it's time to decide. And I think the initial proposition is the relevant one (name convention, backward compatibility, useful, ...). Who (else) is disagreeing to this feature ? ... and who is agreeing ? --001636417499996b4a0484371f11 Content-Type: text/html; charset=ISO-8859-1 Content-Transfer-Encoding: quoted-printable
The option previously proposed is

Float#to_s : human
Float#inspect : verbose

Another option:

Float#to_s : verbose
Float#inspect : verbose
Float#to_hs : human (or to_ps or what not, for pretty string--not sure
if there is a convention for that name or not)

Any feedbacks or preferences there? =A0I'd probably be ok either way. -rp

I think a new name would not be so welcomed (and = confusing).

Why to have two methods (to_s and inspect) doing the sam= e thing?
They are not supposed to be aliased,
this is the case in man= y objects (except the ones having a unique perfect representation).
So let's change one !

I think it's time to decide.
And I = think the initial proposition is the relevant one (name convention, backwar= d compatibility, useful, ...).

Who (else) is disagreeing to this fea= ture ?
... and who is agreeing ?
--001636417499996b4a0484371f11--