From: Kornelius Kalnbach Date: 2010-03-24T03:33:58+09:00 Subject: [ruby-core:28900] Re: [Feature #1961] Kernel#__dir__ On 23.03.10 19:10, Roger Pack wrote: > My personal preference would be __DIR__ ...which suggests that the method is a magic constant like __FILE__. While funny, I don't think it's a good idea. For example, BasicObject wouldn't have access to it. [murphy]