From: Roger Pack Date: 2010-03-03T07:13:20+09:00 Subject: [ruby-core:28429] Re: [Feature #2515] Array#select! > The biggest reason (for me at least) was lack of counterpart of > delete_if, so if keep_if could gain consensus, I'd agree with adding > select! (and keep_if). �I was thinking of delete_unless, but was not > satisfied by the name. +1 for keep_if from me. Seems like a good name. -rp