From: Yukihiro Matsumoto Date: 2010-03-03T04:23:24+09:00 Subject: [ruby-core:28427] Re: [Feature #2515] Array#select! Hi, In message "Re: [ruby-core:28398] [Feature #2515] Array#select!" on Tue, 2 Mar 2010 14:39:39 +0900, Marc-Andre Lafortune writes: |I feel the name select! is as appropriate as map! , collect! and reject! Okay, okay. I understand your feeling. |I would suggest that this feature request be extended to also introduce Array#keep_if. The biggest reason (for me at least) was lack of counterpart of delete_if, so if keep_if could gain consensus, I'd agree with adding select! (and keep_if). I was thinking of delete_unless, but was not satisfied by the name. matz.