From: Magnus Holm Date: 2010-01-05T01:14:02+09:00 Subject: [ruby-core:27390] Re: [Feature #1082] add Object#singleton_class method +1 for whatever. (Okay then, maybe singleton_class is better) //Magnus Holm On Mon, Jan 4, 2010 at 07:25, Yukihiro Matsumoto wrote: > Hi, > > In message "Re: [ruby-core:27372] [Feature #1082] add Object#singleton_class method" > �� ��on Sun, 3 Jan 2010 04:53:36 +0900, Suraj Kurapati writes: > > |Any thoughts on this feature request? > | > | ��hello.singleton_class == (class << hello; self; end) > | > |Thanks for your consideration. > > We haven't met any consensus of a name for the method. > singleton_class, singletonclass, eigenclass, or whatever. > > �� �� �� �� �� �� �� �� �� �� �� �� �� �� �� �� �� �� �� �� �� �� �� �� �� �� �� ��matz. > >