From: Joel VanderWerf Date: 2009-08-25T07:32:19+09:00 Subject: [ruby-core:25107] Re: Proposal: Simpler block format Eric Hodel wrote: > I think multiple procs followed by a block is code smell therefore it > should be difficult to read and clumsy to write by default. Right. And anyway, taking many arguments is code smell, isn't it? To pass more than one proc to a method, we have: run_with_handlers do on :enter do ... end on :leave do ... end on :timeout, 10 do ... end end Is there a compelling example of passing multiple procs in an argument list? The control structure examples, like my_if { #cond }, { #then_clause }, { #else_clause } just don't ring bells for me, since they look clumsy and don't have the same scope rules as syntactic control structures. -- vjoel : Joel VanderWerf : path berkeley edu : 510 665 3407