From: Ian Macdonald Date: 2004-01-19T10:06:49+09:00 Subject: Re: [PATCH] File.readable_world? and File.writable_world? On Mon 19 Jan 2004 at 09:58:40 +0900, Yukihiro Matsumoto wrote: > Hi, > > In message "Re: [PATCH] File.readable_world? and File.writable_world?" > on 04/01/19, Ian Macdonald writes: > > |> OK. Here is the File::Stat patch with associated ChangeLog. > | > |I still don't see this patch applied to CVS. Is it OK, Matz? > > Don't worry. It's OK. I just need to work on other problem before > committing. OK, thanks. Just one more question: I also sent you a patch to lib/pathname.rb last week to implement Pathname#world_readable? and Pathname#world_writable?. Well, the patch seems to have been applied, but then altered. The documentation correctly refers to the above methods, but if I search the file for the actual implementation, I see readable_world? and writable_world? It looks like you changed the names of the methods. Was that your intention? Ian -- Ian Macdonald | I cannot conceive that anybody will require System Administrator | multiplications at the rate of 40,000 or ian@caliban.org | even 4,000 per hour ... -- F. H. Wales http://www.caliban.org | (1936) |