From: Roger Pack Date: 2009-02-19T02:29:26+09:00 Subject: [ruby-core:22219] Re: [Feature #1122] request for: Object#try > IMHO, foo.?bar should behave as "call-except-if-nil". Not only it > would be more consistent with other languages (like Io and Groovy), > but I think it would also be more useful/less dangerous. IMHO there should be two methods, to avoid confusion, and they should be explicitly named, again to avoid confusion. foo.if_not_nil.bar and foo.if_respond_to.bar Thoughts? -=r