From: Meinrad Recheis Date: 2008-09-30T22:58:33+09:00 Subject: [ruby-core:19048] Re: [ANN] Ruby 1.9.1 feature freeze ------=_Part_51625_1982507.1222783172795 Content-Type: text/plain; charset=ISO-8859-1 Content-Transfer-Encoding: 7bit Content-Disposition: inline On Thu, Sep 25, 2008 at 8:49 PM, Ryan Davis wrote: > > On Sep 25, 2008, at 03:33 , daz wrote: > > Respect for defending the English language, Ryan, but this is Ruby. >> >> Note this oddity in English grammar: >> >> 1) It [singular] raises. >> 2) They [plural] raise. >> > > We're talking about assertions in unit tests here. There is never a plural > subject. > > assert_raises reads correctly for both singular and multiple arguments: > > assert (that it) raises (a) SyntaxError. > assert (that it) raises (one of) SyntaxError or ArgumentError. > it depends entirely how you imagine the "missing" words. one could also read it like this: assert (the block to) raise (an) Exception This is, of course, absurd. What I am trying to say is that we should read method names as artificial commands and not as abbreviated English sentences. I'd prefer assert_exception over assert_raise and that over assert_raises. -- henon ------=_Part_51625_1982507.1222783172795 Content-Type: text/html; charset=ISO-8859-1 Content-Transfer-Encoding: 7bit Content-Disposition: inline
On Thu, Sep 25, 2008 at 8:49 PM, Ryan Davis <ryand-ruby@zenspider.com> wrote:

On Sep 25, 2008, at 03:33 , daz wrote:

Respect for defending the English language, Ryan, but this is Ruby.

Note this oddity in English grammar:

 1) It [singular] raises.
 2) They [plural] raise.

We're talking about assertions in unit tests here. There is never a plural subject.

assert_raises reads correctly for both singular and multiple arguments:

assert (that it) raises (a) SyntaxError.
assert (that it) raises (one of) SyntaxError or ArgumentError.

it depends entirely how you imagine the "missing" words. one could also read it like this:

assert (the block to) raise (an) Exception

This is, of course, absurd. What I am trying to say is that we should read method names as artificial commands and not as abbreviated English sentences. I'd prefer assert_exception over assert_raise and that over assert_raises.

-- henon


------=_Part_51625_1982507.1222783172795--