From: Yukihiro Matsumoto Date: 2008-04-12T21:28:31+09:00 Subject: Re: Hash.compare_by_identity Hi, In message "Re: Hash.compare_by_identity" on Thu, 10 Apr 2008 16:42:34 +0900, David Flanagan writes: |Thank you for the clarification. Just so I'm clear, what's wrong with |compare_by_identity as it stands? * compare_by_identity modifies status of the receiving hashes. * the method name is not clear enough; it works as make_hash_compare_its_key_by_identity. * the most use-case is in Rails, for which purpose we already have it in ActiveSupport anyway. matz.