From: Meinrad Recheis Date: 2008-03-14T21:01:50+09:00 Subject: Re: Copy-on-write friendly garbage collector On Fri, Mar 14, 2008 at 12:25 PM, Hongli Lai wrote: > Daniel DeLorme wrote: > > So the GC method could be dynamically changed to cow-friendly just > > before doing a Process.fork... very nice! > > Actually, I'm thinking about requiring the script call "GC.cow_friendly > = true". Most scripts do not fork, and when they do, they usually don't > use it as a means to save memory. > the name cow_friendly could be misinterpreted by some cow boys ^^. how about calling it #copy_on_write_friendly or even better #supports_copy_on_write ? cow, fork ... *chuckle* -- henon