From: hemant Date: 2007-12-26T04:43:51+09:00 Subject: Re: Legacy support (Was: Base64 not there makes Rails 2.0.2 fail to load in 1.9.0) On Dec 26, 2007 1:01 AM, M. Edward (Ed) Borasky wrote: > > Eric Hodel wrote: > > On Dec 25, 2007, at 07:03 AM, Richard Kilmer wrote: > >> Just re-built latest svn of 1.9.0 and base64.rb is removed. Its > >> required in active_support (conversions.rb). Do you think its worth > >> having all libraries that were removed from Ruby in 1.9.0 moved into a > >> "legacy gem" or something? I am sure the rails guys will catch this > >> and remove the dependency since its not going to be supported going > >> forward, but this kind of thing may happen to other libraries. > > > > I don't think a legacy gem should be created. This doesn't encourage > > people to switch to the new way of doing things, whatever that is. (For > > base64, use [str].pack 'm*'.) > > > > People have asked me to alias require_gem for RubyGems 1.x, and I will > > not. Software depending on it won't get fixed if it stays around. > > > > > > Yeah ... I'm with you on this one, having just discovered that two gems, > rcov and hpricot, need to be updated to work with 1.9 anyhow. Should > there be some kind of "master list" of the "commonly used gems" that > need updating so they'll work with either 1.8 or 1.9? So far I have > > 1. rcov > 2. hpricot > 3. active_support > Yes lots, Almost ALL C extensions would require some kinda tinkering. My broken lib list is: mysql, mongrel, eventmachine -- Let them talk of their oriental summer climes of everlasting conservatories; give me the privilege of making my own summer with my own coals. http://gnufied.org