From: SASADA Koichi Date: 2007-12-24T15:29:00+09:00 Subject: Re: Many external symbols _without_ prefix in libruby object file Hi, Tadashi Saito wrote: > - (NEW_DVAR(e), idLT, new_ary(NEW_DVAR(_self), 0)), > + (NEW_DVAR(e), '<', new_ary(NEW_DVAR(_self), 0)), IMO, it's easy to recognize ID insteand of single character. If idFoo is not good name, all symbols should be renamed clear name such as rb_idFoo. And use macro such as "#define rb_idLT '<'". Regards, -- // SASADA Koichi at atdot dot net