From: Tanaka Akira Date: 2007-11-12T14:08:08+09:00 Subject: Re: primary encoding and source encoding In article <20071112045907.D13F4E049C@mail.bc9.jp>, Nobuyoshi Nakada writes: >> How about renaming it to "default file encoding"? > > Move to `IO.default_encoding'? I feel it is applied to sockets but actually not. Although I know it is applied to stdin, I think File.default_encoding is better. -- Tanaka Akira