From: Jordi Date: 2007-11-12T11:00:55+09:00 Subject: Re: method names in 1.9 Summing it up: - Surprising or not, sending messages is not the same that calling methods in Ruby (there is a real difference, see method_missing email of Matthew in this thread). - Honoring visibility is not the same that don't honoring it (obviously) So, we can have potentially 4 operations in Ruby 1.8.x: 1.- Call method honoring visibility 2.- Call method not honoring visibility 3.- Send message honoring visibility 4.- Send message not honoring visibility In Ruby 1.8.x , 1 is implemented with "." and 4 is implemented with "send". AFAIK, 2 and 3 are not implemented. IMHO they don't need to! The difference between sending a message and calling a method is so subtle (in real Ruby implemented world) that most of the times can be used like the honoring/not honoring pair of the same operation. My personal opinion is make "." behave like "send" respect to method_missing. In other words, move "." from 1 to 3. Then kill the "call method" concept in Ruby. As I think that concept __is not intended to exist__ in the language anyway. Also I'd rename "send" for something more like "respond" as the object is not sending but receiving, but that is much more of a personal taste. :P -- Jordi