From: Voroztsov Artem Date: 2007-11-11T20:25:44+09:00 Subject: Re: new Enumerable.butfirst method 2007/10/31, Yukihiro Matsumoto : > I just changed with-block form of #take and #drop to #take_while and > #drop_while respectively. After those change figure becomes Maybe #take_if and #drop_if will be better? Names #take_while and #drop_while make me think that it stops taking and dropping when block returns false/nil for the first time. artem