From: Jordi Date: 2007-11-11T14:22:48+09:00 Subject: Re: method names in 1.9 On Nov 11, 2007 2:33 AM, Yukihiro Matsumoto wrote: > Hi, > > In message "Re: method names in 1.9" > on Sun, 11 Nov 2007 02:11:53 +0900, "David A. Black" writes: > > |> - send, invoke_method > > |I agree (no bang for safer version). I guess my favorite was send > |(safe) with send! (dangerous). I'm not sure what the best solution is > |if send is back to being the dangerous one. > > I don't think it's a good idea to inverse it for bang's sake. It > doesn't worth sacrifice compatibility. I know that I'll be at best ignored by this comment but when I discovered send, I thought it was how the object sends or emits some kind of information to the outer world. I discovered later that Object.send means Object __receives__ the call of a method. Creating a receive method now is a crazy idea of course, I only argue that the name "send" may not be the best one. What about invoke_method and invoke_method!, send becaming deprecated but usable till next big release, meaning invoke_method! ? -- Jordi Polo