From: ts Date: 2003-07-20T18:51:03+09:00 Subject: Re: [Patch] FTP.new with block >>>>> "R" == Richard Zidlicky writes: R> something more systematic is needed. So far only 2 widely used R> classes appear to evaluate blocks passed to new: Proc and Tk. svg% ruby -e 'p Array.new(2) { 12 }' [12, 12] svg% svg% ruby -e 'a = Hash.new { 12 }; p a[1]' 12 svg% R> Furthermore Tk is somehwat confusing for the beginner because R> it uses instance_eval or something completely different to eval R> the block. Why a method must eval the block when it's called ? See Hash::new R> How to get it consistent? Leave the 2 widely used exceptions R> to the rule (no block arg for new) some time to phase out and R> use either a clear naming convention (eg new_wb instead of new) and change the name of *all* methods to have _wb when they use a block ? Guy Decoux