From: murphy Date: 2007-09-11T13:19:37+09:00 Subject: Re: Proposal: runtime-modifying Kernel methods should be keywords James Edward Gray II schrieb: >> gsub sets $_ in the caller's scope. > > Which is probably another feature of questionable value. I know it's > handy in one-liners, but outside of that code using $_ has been out of > fashion for some time now. Is it? I've scanned my local gems, and 29 of 34 use $0-9 somewhere. For example, Rails and HighLine. Actually, I like it better than MatchData. Please don't change Ruby too much for performance reasons. It seems that making local_variables a keyword (or a magic constant like __LINE__) doesn't change the power of the language, since I can't make use of its method-ness anyway. But dumping $0 and friends for a little more speed seems too much, even for Ruby 2.0. [murphy]