From: Yukihiro Matsumoto Date: 2007-07-13T15:48:19+09:00 Subject: Re: Proposal: runtime-modifying Kernel methods should be keywords Hi, In message "Re: Proposal: runtime-modifying Kernel methods should be keywords" on Fri, 13 Jul 2007 15:42:06 +0900, Charles Oliver Nutter writes: |I'd say anything that fits both of the following criteria qualifies: | |- the feature can't be implemented without knowing how to manipulate |runtime/implementation-specific structures (and having a way to |manipulate those structures) |- the feature can't be wrapped in another method and maintain the same |behavior as if it were called in the original context | |All those listed so far fit these criteria. String#gsub ? matz.